Mandriva Fórum

Hardware v Mandriva Linuxu => Tiskárny a skenery => : krizak November 16, 2009, 18:35:35



: HPLIP Driver Plug-in Software
: krizak November 16, 2009, 18:35:35
Nedávno jsem dostal tiskárnu HP LaserJet P1505, která je sice podporována HPLIP od verze 3.9.2, ale ten po instalaci tiskárny vyžaduje stažení a instalaci dodatečného pluginu. Ten není pod svobodnou licencí.
V MDV 2010 RC2 mi HPLIP 3.9.8 plugin stáhnul a nainstaloval, teď v konečné verzi MDV 2010 (KDE  4.3.2) sice plugin stáhne, ale instalace skončí neúspěšně a tiskárna nejede. Původně jsem si myslel, že by mohl být problém v mém pomalém připojení k internetu přes mobil. Pak jsem to zkusil v Ubuntu 9.10 (HPLIP rovněž 3.9.8.), tam se plugin stáhnul a nainstaloval správně. Tak nevím, že by chyba v Mandrivě?


: Re: HPLIP Driver Plug-in Software
: Hobil November 16, 2009, 18:39:53
nejake chybove hlaseni by nebylo?
nazev pluginu by nebyl?
neni-li plugin svobodny, asi nebude v repozitarich - neni mozne, ze neni dostupna stranak vyrobce, nebo nejak zmenena?
H.


: Re: HPLIP Driver Plug-in Software
: vallonew November 16, 2009, 18:45:13
Nedávno jsem dostal tiskárnu HP LaserJet P1505, která je sice podporována HPLIP od verze 3.5.2, ale ten po instalaci tiskárny vyžaduje stažení a instalaci dodatečného pluginu. Ten není pod svobodnou licencí.
V MDV 2010 RC2 mi HPLIP 3.5.8 plugin stáhnul a nainstaloval, teď v konečné verzi MDV 2010 (KDE  4.3.2) sice plugin stáhne, ale instalace skončí neúspěšně a tiskárna nejede. Původně jsem si myslel, že by mohl být problém v mém pomalém připojení k internetu přes mobil. Pak jsem to zkusil v Ubuntu 9.10 (HPLIP rovněž 3.5.8.), tam se plugin stáhnul a nainstaloval správně. Tak nevím, že by chyba v Mandrivě?
Mám nainstalovaný HP LIP verzi 3.9.8 a v pohodě. Mám HP Photosmart C4480. Problém při první instalaci nebyl. Při druhé instalaci mi nejel scanner, trvalo mi asi 1,5 hod. než jsem zjistil, že musím tu tiskárnu odpojit a pak tu šňůru zase zapojit, poté instalace proběhla v pohodě. U mě HP LIP si všechno stáhne sám a nesmím to začít instalovat z ovladacího centra.


: Re: HPLIP Driver Plug-in Software
: krizak November 16, 2009, 18:52:23
Bohužel název pluginu jsem nikde nevystopoval, ani na stránkách HPLIP. Tam se jen píše o tom, že existuje, že některé tiskárny ho mohou vyžadovat a že není pod svobodnou licencí. Na stránkách HP jsem se také ničeho nedobral.
Pro chybové hlášení si budu muset v noťasu přehodit disk, takže to bude chvilku trvat. Teď "jedu" ze "zkušebního" disku s Ubuntu.


: Re: HPLIP Driver Plug-in Software
: krizak November 17, 2009, 17:19:08
Takže jsem se dopátral patřičného pluginu na adrese: http://www.linuxprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.9.8-plugin.run
Bohužel, HPLIP 3.9.8 v MDV 2010 mi ho nenainstaluje ani při ručním výběru souboru.


: Re: HPLIP Driver Plug-in Software
: Peťoš November 17, 2009, 17:20:09
Bohužel, HPLIP 3.9.8 v MDV 2010 mi ho nenainstaluje ani při ručním výběru souboru.
Prozradíš více? Jak to zadáváš, co to píše atd.?


: Re: HPLIP Driver Plug-in Software
: krizak November 18, 2009, 18:13:20
Zadávám to v programu HP Device Manager na kartě "Actions", položka "Instal required Plugin". První možností je "Download and install the plug-in from an HP authorized server (recommended). Po zvolení stahuje z netu plugin, potom vyskočí okno pro potvrzení licenčních podmínek. Po potvrzení vyskočí hláška "Plugin install failed". Je to asi 14 dnů, co jsem tiskárnu přinesl domů a plugin se touto cestou normálně nainstaloval. Teď ne.

Výpis:
[krizak@localhost ~]$ su
Password:               
[root@localhost krizak]# tailf /var/log/messages
Nov 18 16:53:01 localhost CROND[13058]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:54:01 localhost CROND[13504]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:55:01 localhost CROND[13950]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:55:53 localhost drakconf.real[14350]: ### Program is starting ###     
Nov 18 16:55:57 localhost drakconf.real[14365]: ### Program is starting ###     
Nov 18 16:56:01 localhost CROND[14385]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:56:03 localhost rpmdrake[14415]: ### Program is starting ###         
Nov 18 16:56:05 localhost rpmdrake[14415]: opening the RPM database             
Nov 18 16:56:51 localhost drakconf.real[14365]: modified file /etc/mcc.conf     
Nov 18 16:57:01 localhost CROND[14738]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:57:34 localhost klogd: usb 2-4: new high speed USB device using ehci_hcd and address 23                                                               
Nov 18 16:57:34 localhost klogd: usb 2-4: New USB device found, idVendor=03f0, idProduct=3f17                                                                   
Nov 18 16:57:34 localhost klogd: usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 18 16:57:34 localhost klogd: usb 2-4: Product: HP LaserJet P1505
Nov 18 16:57:34 localhost klogd: usb 2-4: Manufacturer: Hewlett-Packard
Nov 18 16:57:34 localhost klogd: usb 2-4: SerialNumber: CA9325D
Nov 18 16:57:34 localhost klogd: usb 2-4: configuration #1 chosen from 1 choice
Nov 18 16:57:34 localhost klogd: usblp0: USB Bidirectional printer dev 23 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3F17
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:57:58 localhost klogd: usblp0: removed
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:58:01 localhost CROND[15278]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 16:59:01 localhost CROND[15566]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:00:01 localhost CROND[15813]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:00:53 localhost python: hp-pkservice[15317]: error: Session not authorized by PolicyKit version 1
Nov 18 17:00:53 localhost python: hp-plugin[15318]: error: Plug-in install failed.
Nov 18 17:01:01 localhost CROND[16128]: (root) CMD (nice -n 19 run-parts --report /etc/cron.hourly)
Nov 18 17:01:01 localhost CROND[16131]: (root) CMD (   /usr/share/msec/promisc_check.sh)


: Re: HPLIP Driver Plug-in Software
: Peťoš November 18, 2009, 18:15:11
Nov 18 17:00:53 localhost python: hp-pkservice[15317]: error: Session not authorized by PolicyKit version 1
Vypni msec. Úplně, totálně, vypnout. Pak by to snad mohlo naskočit.


: Re: HPLIP Driver Plug-in Software
: krizak November 18, 2009, 19:06:43
Vypnul jsem MSEC v ovládacím centru. Pro jistotu jsem restartoval počítač a automatická instalace pluginu přesto skončí chybou. Pokud zvolím možnost instalace souboru uloženého na disku, neudělá to pro jistotu vůbec nic.

Výpis:
Nov 18 17:56:00 localhost mdkapplet[3599]: Packages are up to date
Nov 18 17:56:01 localhost CROND[12711]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:57:02 localhost CROND[14000]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:57:09 localhost python: hp-pkservice[11480]: error: Session not authorized by PolicyKit version 1
Nov 18 17:57:09 localhost python: hp-plugin[11483]: error: Plug-in install failed.
Nov 18 17:58:01 localhost CROND[15240]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:59:01 localhost CROND[16473]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 18:00:01 localhost CROND[17705]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 18:00:19 localhost python: hp-pkservice[14849]: error: Session not authorized by PolicyKit version 1
Nov 18 18:00:19 localhost python: hp-plugin[14850]: error: Plug-in install failed.
Nov 18 18:01:01 localhost CROND[18990]: (root) CMD (nice -n 19 run-parts --report /etc/cron.hourly)
Nov 18 18:01:01 localhost CROND[18992]: (root) CMD (   /usr/share/msec/promisc_check.sh)

V Ubuntu se to opět normálně stáhne a nainstaluje.  V Mandrivě to před cca 14 dny šlo taky.


: Re: HPLIP Driver Plug-in Software
: vallonew November 18, 2009, 20:23:08
V Mandrivě to před cca 14 dny šlo taky.

Tak ještě pro jistotu se ozývám. U mě byl problém s instalací HP LIP, protože jsem nevěděl, že musím tu tiskárnu odpojit od USB a ihned zapojit. Tím si samo řeklo, že to chce nainstalovat a stáhlo se vše bez problémů. Když jsem koupil moji tiskárnu, tak nebyl problém. Druhá instalace nešla, protože tiskárna byla připojená. Později jsem právě zjistil proč to nejde. Musel jsem všechno odinstalovat a pak připojit USB a jen potvrzovat. Nevím jestli to pomůže, ale co kdyby?   :D


: Re: HPLIP Driver Plug-in Software
: krizak November 18, 2009, 21:04:19
Ony jsou tiskárny, které jsou podporovány HPLIP plně, jiné vůbec a některé s nutností stažení pluginu. Ta moje je ten poslední případ. Takže po připjení do USB Mandriva tiskárnu najde, nainstaluje, dokonce se tváří, že tiskne, ale z tiskárny nic neleze (před časem se tu objevil podobný problém s jinou tiskárnou). Teprve po stažení a nainstalování pluginu (a vytažení káblíku a opětovném zasunutí) se tisk doopravdy rozběhne. V MDV 2010 RC2 to zafungovalo bez problému, takže v konečné verzi jsem problém neočekával...


: Re: HPLIP Driver Plug-in Software
: krizak November 18, 2009, 23:31:31
Takže ještě jeden, a možná docela důležitý, poznatek: Zkusil jsem tiskárnu HP LaserJet P1505 nainstalovat v MDV 2009.1, HPLIP 3.9.2; po zvolení možnosti "Download and install the plug-in from an HP authorized server (recommended) si to řeklo o HESLO SPRÁVCE SYSTÉNU a plugin se po té stáhnul a správně nainstaloval. Obdobně v Ubuntu 9.10 (HPLIP 3.9.8.) jsem v průběhu instalace tiskárny zadával heslo. MDV 2010 (HPLIP 3.9.8.) si o heslo neříká a plugin se nenainstaluje. Že by přece jen nakonec chybka v systému? Pokud ano, předesílám, že mé chabé znalosti angličtiny mi nedovolují ohlásit to do bugzilly  :(


: Re: HPLIP Driver Plug-in Software
: Peťoš November 18, 2009, 23:34:29
a spouštíš to jako superuživatel root??


: Re: HPLIP Driver Plug-in Software
: krizak November 18, 2009, 23:37:37
Ne, protože při předchozí instalaci v MDV 2010 RC2 (a pak v Ubuntu a v MDV 2009.1) si to o heslo řeklo v průběhu instalace samo. Ale zkusím to.


: Re: HPLIP Driver Plug-in Software
: krizak November 18, 2009, 23:43:34
[root@localhost krizak]# hp-toolbox
warning: hp-toolbox should not be run as root/superuser.


: Re: HPLIP Driver Plug-in Software
: Peťoš November 18, 2009, 23:46:45
[root@localhost krizak]# hp-toolbox
warning: hp-toolbox should not be run as root/superuser.
OK, pokus se tu chybu zformulovat pokud možno přesně česky a pokud mozno s kompletní dokumentací a postupem reprodukce problému.


: Re: HPLIP Driver Plug-in Software
: Peťoš November 20, 2009, 12:32:10
Chyba je způsobena tím, že si nově v 2010.0 HPLIP o heslo roota žádá přes POLKIT -- nová bezpečností vrstva, konkrétně polkit-gnome-authentication-agent-1. Problém je v tom, že tento startuje pouze v GNOME. Pokud tedy pracujete v GNOME, tak na žádnou chybu při instalaci pluginu nanarazíte. Naopak pokud v GNOME nepracujete, dialog žádající si heslo roota neuvidíte a tedy plugin nenainstalujete. Chybu jsem nahlásil do bugzilly (#55801) a pracuje se na jejím odstranění.

Workaround pro všechny:
pred tim, nez se pokusíte nainstalovat plugin, je treba spustit terminál a napsat:

32bitový systém:
/usr/lib/polkit-gnome-authentication-agent-1 &

64bitový systém:
/usr/lib64/polkit-gnome-authentication-agent-1 &

Poté klasicky zavřete terminál příkazem exit po spuštění HPLIB-toolboxu (toho nastavovátka) stačí klepnout na Actions > Install plugin. Tentokrát si o heslo řekne.


: Re: HPLIP Driver Plug-in Software
: Rostislav Pavlik October 18, 2011, 20:43:56
Mam podobny problem. Dnes som kupil tlaciaren  HP Laserjet Pro M1132 MFP,  HPLIP 3.11.5 vyzaduje plugin, ale pri instalacii hlasi " ERROR: Plug-in file does not match its digital signature. File may have been corrupted or altered. Error code: 2" Mandrivalinux 32bit 2010.2, Gnome. Ale to uz ubehlo dost vela casu, tak to bude asi iny problem, ze? Mozete niekto poradit?


: Re: HPLIP Driver Plug-in Software
: pert2 October 18, 2011, 21:13:37
Možná se jedná o tento bug:
http://lists.mandriva.com/bugs/2009-03/msg03767.php

Píší tam o řešení nastavovat přes system-config-printer nebo si doinstalovat balíček gksu a spouštět to jako:
gksu  hp-toolbox.

Další, zdá se stejný bug:
http://lists.mandriva.com/bugs/2009-03/msg03754.php
Píší tam o řešení přidat  /usr/lib/kde4/libexec  do $PATH.
Asi by mělo stačit přidat do ~/.bashrc řádek:
PATH=$PATH:/usr/lib/kde4/libexec



: Re: HPLIP Driver Plug-in Software
: Peťoš October 18, 2011, 21:15:18
Ne, jedna se o toto:
http://forum.mandrivalinux.cz/index.php?topic=9601.30\
resp.
http://www.e-ott.info/2011/04/11/jak-nainstalovat-a-nastavit-skener-v-zarizenich-hewlett-packard-ovladac-hplip


: Re: HPLIP Driver Plug-in Software
: Rostislav Pavlik October 18, 2011, 22:48:15
Ne, jedna se o toto:
http://forum.mandrivalinux.cz/index.php?topic=9601.30\
resp.
http://www.e-ott.info/2011/04/11/jak-nainstalovat-a-nastavit-skener-v-zarizenich-hewlett-packard-ovladac-hplip
Je tam pekny navod ako nainstalovat plug-in, ale cielovy link nefunguje, neviete nahodou kde inde by sa dal stiahnut ten plug-in?


: Re: HPLIP Driver Plug-in Software
: Rostislav Pavlik October 19, 2011, 18:34:24
Plug-in som nasiel, nainstaloval podla uvedeneho navodu, restartoval a podobne, ale tlaciaren nie a nie rozchodit. Ked spustim tlac, tlaciaren zablika, ale to je vsetko. Scaner, ktory je na nej, tiez reaguje, dokonca aj prebehne scanovanie, ale vysledok je nulovy. Uz som si s instalaciou tejto tlaciarne rozhasil Mandrivu 2010.2, tak som si nainstaloval Mageiu, ale k vysledku som sa nedopracoval.


: Re: HPLIP Driver Plug-in Software
: Rostislav Pavlik October 20, 2011, 08:18:51
Tlacovy system mi ponukol diagnostiku a vytvoril dlhu chybovu spravu, ktoru prikladam v prilohe. Samozrejme, ze jej nerozumiem, ak by mi niekto bol ochotny pomoct. Moc dakujem.


: Re: HPLIP Driver Plug-in Software
: Rostislav Pavlik October 23, 2011, 10:36:46
Tak som sa pokusil riesit problem sposobom nainstalovania inej distribucie. Konkretne som nainstaloval Ubuntu 11.10 a vsetko som velmi rychlo rozchodil, tlaciaren aj scaner. Neviem teda kde je chyba, vyzera to tak ze ostanem pri UBuntu. Pocitujem trochu nostalgiu, Mandriva bola moja prva Linuxova distribuci na ktorej som pracoval asi 6 rokov, zial som nuteny ju opustit.


: Re: HPLIP Driver Plug-in Software
: Hobil October 24, 2011, 07:13:45
Ve vypisu me zaujala tahle cast:
:
  {'packages_verification': {'cups': ['..?......  c /etc/cups/cupsd.conf',
                                    '..?......    /etc/cups/cupsd.conf.default',
                                    '..?......  c /etc/cups/snmp.conf',
                                    '..?......    /usr/lib/cups/backend/dnssd',
                                    '..?......    /usr/lib/cups/backend/ipp',
                                    '..?......    /usr/lib/cups/backend/lpd',
                                    'missing     /var/spool/cups/tmp (Permission denied)'],
                           'foomatic': ['package foomatic is not installed'],
                           'gutenprint': ['package gutenprint is not installed'],
                           'hpijs': ['package hpijs is not installed'],
                           'hplip': ['SM?....T.    /usr/share/hplip/installer/core_install.pyc',
                                     'S.5....T.    /var/lib/hp/hplip.state'],
                           'system-config-printer': []}}
Nejsem si jisty, jestli nektere balicky ten hplip nepotrebuje, tedy hpijs a foomatic. Divna je i hlaska o "/var/spool/cups/tmp (Permission denied)", takze bych zkontroloval, zda soubor existuje a jaka ma nastavena prava, pripadne ho vytvoril nebo prenastavil.
Pro nastavovani CUPSu bych doporucil pouzit jejich rozhrani na localhost:631, vsechny ostatni nastroje se snazi delat totez, ale ne vzdy musi fungovat 100%.

V tuhle chvili bych odinstaloval vse, co se tisku tyka vcetne CUPS, vcetne konfiguracnich souboru a zacal nanovo, s nastavenim vseho ve webovem rozhrani CUPSu.
H.


: Re: HPLIP Driver Plug-in Software
: starsi November 16, 2011, 13:24:52
Ako som tu už písal skúšal som všetko, aby som rozchodil moju tlačku HP laseJet 1020. Dokonca som to hodil aj na Ubuntu. Nešla ani za "svätého ...". Skúšal som všetky distribúcie linuxu (ktoré som mal po ruke - opensuse, fedora, mandriva, mageia - vo verziách 32b aj 64b) nainštalovať, ani jedna sa nechytala. Potom som niečo pobabral, ale neviem čo. Vo verzii desktop (ani v jednej distribúcii) sa mi nedala pripojiť časť "home". Vykazovalo to nejaké poškodené súbory a inštalácia padala pri reštarte. Keď som inštaloval verzie "live z CD"  časť "home" som videl mohol som do nej zapisovať po zadaní hesla aspoň sa to tak tvárilo. Podstatné bolo, že som stiahol všetky dáta na záložný disk. Rozhodol som sa ešte raz všetko nainštalovat ale s celým preformátovaním disku. Urobil som to cez ubuntu, ktoré som nainštaloval. Spustil som tlačku a ďalej som len odklikával a všetko sa v pohode nainštalovalo. Na skúšku som si vytlačil nejaké papiere, reštartoval som to a znova som skúšal. Tlačka fungovala v pohode. Rozhodol som sa prejsť na mageiu. Celý disk som preformátoval a na čistý disk som nainštaloval na novo celú mageiu. Dopadlo to dobre tlačka mi ide. Postup bude na fóre MAGEIA potom sem pridám aj link.   

http://forum.mageia.cz/index.php?topic=60.new#new


: Re: HPLIP Driver Plug-in Software
: Volkov December 27, 2011, 11:19:02
Dobrý den dostali jsme tiskárnu HP B110 a dokumenty tiskne dobře z prohlížeče obrázků tiskne dobře a když dám tisk v HP device manegeru tak to vytiskne http://2i.cz/2e3ce3c91a jako určitě to bude problém mezi klávesnicí a židlí :D a nechce se mi to dělat pokus omyl (hlavně kvuli barvam a papíru ) díky za info. Dělá to jen u fotek co sou focený s fotáku třeba vyfocená obrazovka s print screenem to nedělá nechápu to.
 A ještě bych se chtěl jestli je nějaký program  kde by se dali seřadit 4 malí fotky aby to vytisklo na  A4 



Mám MDV 2010


: Re: HPLIP Driver Plug-in Software
: Peťoš December 27, 2011, 13:16:21
proboha nepouzivajte ty straslive ulozny obrazku! Je to pomale, hrozne a navic za cas to zmizi a tema bude... podivne. Dole pod polem pro psani prispevku jsou Rozsirene moznosti. Priloz to pomoci nich.


: Re: HPLIP Driver Plug-in Software
: Ivko December 27, 2011, 22:28:53
A ještě bych se chtěl jestli je nějaký program  kde by se dali seřadit 4 malí fotky aby to vytisklo na  A4 

A čo tak skúsiť jednoduchý a prístupný LibreOffice - Draw?


: Re: HPLIP Driver Plug-in Software
: Volkov December 28, 2011, 11:27:56
Ok díky Open Office to jeistí díky nic víc netřeba vyřešeno