Přihlásit
: [1] 2
   |   
: HPLIP Driver Plug-in Software  ( 16069 )
krizak
Full Member
***

Karma: 1
: 216


301550699
« : November 16, 2009, 18:35:35 »

Nedávno jsem dostal tiskárnu HP LaserJet P1505, která je sice podporována HPLIP od verze 3.9.2, ale ten po instalaci tiskárny vyžaduje stažení a instalaci dodatečného pluginu. Ten není pod svobodnou licencí.
V MDV 2010 RC2 mi HPLIP 3.9.8 plugin stáhnul a nainstaloval, teď v konečné verzi MDV 2010 (KDE  4.3.2) sice plugin stáhne, ale instalace skončí neúspěšně a tiskárna nejede. Původně jsem si myslel, že by mohl být problém v mém pomalém připojení k internetu přes mobil. Pak jsem to zkusil v Ubuntu 9.10 (HPLIP rovněž 3.9.8.), tam se plugin stáhnul a nainstaloval správně. Tak nevím, že by chyba v Mandrivě?
« : November 17, 2009, 17:15:49 krizak »

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
Hobil
Hero Member
*****

Karma: 58
: 4 006


« #1 : November 16, 2009, 18:39:53 »

nejake chybove hlaseni by nebylo?
nazev pluginu by nebyl?
neni-li plugin svobodny, asi nebude v repozitarich - neni mozne, ze neni dostupna stranak vyrobce, nebo nejak zmenena?
H.

Benzínem se nemá hasit ohniště
teď už je to jedno, ale pro příště... (K.P.)
vallonew
Hero Member
*****

Karma: 8
: 801



« #2 : November 16, 2009, 18:45:13 »

Nedávno jsem dostal tiskárnu HP LaserJet P1505, která je sice podporována HPLIP od verze 3.5.2, ale ten po instalaci tiskárny vyžaduje stažení a instalaci dodatečného pluginu. Ten není pod svobodnou licencí.
V MDV 2010 RC2 mi HPLIP 3.5.8 plugin stáhnul a nainstaloval, teď v konečné verzi MDV 2010 (KDE  4.3.2) sice plugin stáhne, ale instalace skončí neúspěšně a tiskárna nejede. Původně jsem si myslel, že by mohl být problém v mém pomalém připojení k internetu přes mobil. Pak jsem to zkusil v Ubuntu 9.10 (HPLIP rovněž 3.5.8.), tam se plugin stáhnul a nainstaloval správně. Tak nevím, že by chyba v Mandrivě?
Mám nainstalovaný HP LIP verzi 3.9.8 a v pohodě. Mám HP Photosmart C4480. Problém při první instalaci nebyl. Při druhé instalaci mi nejel scanner, trvalo mi asi 1,5 hod. než jsem zjistil, že musím tu tiskárnu odpojit a pak tu šňůru zase zapojit, poté instalace proběhla v pohodě. U mě HP LIP si všechno stáhne sám a nesmím to začít instalovat z ovladacího centra.
krizak
Full Member
***

Karma: 1
: 216


301550699
« #3 : November 16, 2009, 18:52:23 »

Bohužel název pluginu jsem nikde nevystopoval, ani na stránkách HPLIP. Tam se jen píše o tom, že existuje, že některé tiskárny ho mohou vyžadovat a že není pod svobodnou licencí. Na stránkách HP jsem se také ničeho nedobral.
Pro chybové hlášení si budu muset v noťasu přehodit disk, takže to bude chvilku trvat. Teď "jedu" ze "zkušebního" disku s Ubuntu.

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
krizak
Full Member
***

Karma: 1
: 216


301550699
« #4 : November 17, 2009, 17:19:08 »

Takže jsem se dopátral patřičného pluginu na adrese: http://www.linuxprinting.org/download/printdriver/auxfiles/HP/plugins/hplip-3.9.8-plugin.run
Bohužel, HPLIP 3.9.8 v MDV 2010 mi ho nenainstaluje ani při ručním výběru souboru.

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #5 : November 17, 2009, 17:20:09 »

Bohužel, HPLIP 3.9.8 v MDV 2010 mi ho nenainstaluje ani při ručním výběru souboru.
Prozradíš více? Jak to zadáváš, co to píše atd.?

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
krizak
Full Member
***

Karma: 1
: 216


301550699
« #6 : November 18, 2009, 18:13:20 »

Zadávám to v programu HP Device Manager na kartě "Actions", položka "Instal required Plugin". První možností je "Download and install the plug-in from an HP authorized server (recommended). Po zvolení stahuje z netu plugin, potom vyskočí okno pro potvrzení licenčních podmínek. Po potvrzení vyskočí hláška "Plugin install failed". Je to asi 14 dnů, co jsem tiskárnu přinesl domů a plugin se touto cestou normálně nainstaloval. Teď ne.

Výpis:
[krizak@localhost ~]$ su
Password:               
[root@localhost krizak]# tailf /var/log/messages
Nov 18 16:53:01 localhost CROND[13058]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:54:01 localhost CROND[13504]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:55:01 localhost CROND[13950]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:55:53 localhost drakconf.real[14350]: ### Program is starting ###     
Nov 18 16:55:57 localhost drakconf.real[14365]: ### Program is starting ###     
Nov 18 16:56:01 localhost CROND[14385]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:56:03 localhost rpmdrake[14415]: ### Program is starting ###         
Nov 18 16:56:05 localhost rpmdrake[14415]: opening the RPM database             
Nov 18 16:56:51 localhost drakconf.real[14365]: modified file /etc/mcc.conf     
Nov 18 16:57:01 localhost CROND[14738]: (root) CMD (   /usr/share/msec/promisc_check.sh)                                                                       
Nov 18 16:57:34 localhost klogd: usb 2-4: new high speed USB device using ehci_hcd and address 23                                                               
Nov 18 16:57:34 localhost klogd: usb 2-4: New USB device found, idVendor=03f0, idProduct=3f17                                                                   
Nov 18 16:57:34 localhost klogd: usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 18 16:57:34 localhost klogd: usb 2-4: Product: HP LaserJet P1505
Nov 18 16:57:34 localhost klogd: usb 2-4: Manufacturer: Hewlett-Packard
Nov 18 16:57:34 localhost klogd: usb 2-4: SerialNumber: CA9325D
Nov 18 16:57:34 localhost klogd: usb 2-4: configuration #1 chosen from 1 choice
Nov 18 16:57:34 localhost klogd: usblp0: USB Bidirectional printer dev 23 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3F17
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:57:58 localhost klogd: usblp0: removed
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:57:58 localhost python: io/hpmud/musb.c 594: invalid usb_open: Permission denied
Nov 18 16:58:01 localhost CROND[15278]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 16:59:01 localhost CROND[15566]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:00:01 localhost CROND[15813]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:00:53 localhost python: hp-pkservice[15317]: error: Session not authorized by PolicyKit version 1
Nov 18 17:00:53 localhost python: hp-plugin[15318]: error: Plug-in install failed.
Nov 18 17:01:01 localhost CROND[16128]: (root) CMD (nice -n 19 run-parts --report /etc/cron.hourly)
Nov 18 17:01:01 localhost CROND[16131]: (root) CMD (   /usr/share/msec/promisc_check.sh)

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #7 : November 18, 2009, 18:15:11 »

Nov 18 17:00:53 localhost python: hp-pkservice[15317]: error: Session not authorized by PolicyKit version 1
Vypni msec. Úplně, totálně, vypnout. Pak by to snad mohlo naskočit.

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
krizak
Full Member
***

Karma: 1
: 216


301550699
« #8 : November 18, 2009, 19:06:43 »

Vypnul jsem MSEC v ovládacím centru. Pro jistotu jsem restartoval počítač a automatická instalace pluginu přesto skončí chybou. Pokud zvolím možnost instalace souboru uloženého na disku, neudělá to pro jistotu vůbec nic.

Výpis:
Nov 18 17:56:00 localhost mdkapplet[3599]: Packages are up to date
Nov 18 17:56:01 localhost CROND[12711]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:57:02 localhost CROND[14000]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:57:09 localhost python: hp-pkservice[11480]: error: Session not authorized by PolicyKit version 1
Nov 18 17:57:09 localhost python: hp-plugin[11483]: error: Plug-in install failed.
Nov 18 17:58:01 localhost CROND[15240]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 17:59:01 localhost CROND[16473]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 18:00:01 localhost CROND[17705]: (root) CMD (   /usr/share/msec/promisc_check.sh)
Nov 18 18:00:19 localhost python: hp-pkservice[14849]: error: Session not authorized by PolicyKit version 1
Nov 18 18:00:19 localhost python: hp-plugin[14850]: error: Plug-in install failed.
Nov 18 18:01:01 localhost CROND[18990]: (root) CMD (nice -n 19 run-parts --report /etc/cron.hourly)
Nov 18 18:01:01 localhost CROND[18992]: (root) CMD (   /usr/share/msec/promisc_check.sh)

V Ubuntu se to opět normálně stáhne a nainstaluje.  V Mandrivě to před cca 14 dny šlo taky.

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
vallonew
Hero Member
*****

Karma: 8
: 801



« #9 : November 18, 2009, 20:23:08 »

V Mandrivě to před cca 14 dny šlo taky.

Tak ještě pro jistotu se ozývám. U mě byl problém s instalací HP LIP, protože jsem nevěděl, že musím tu tiskárnu odpojit od USB a ihned zapojit. Tím si samo řeklo, že to chce nainstalovat a stáhlo se vše bez problémů. Když jsem koupil moji tiskárnu, tak nebyl problém. Druhá instalace nešla, protože tiskárna byla připojená. Později jsem právě zjistil proč to nejde. Musel jsem všechno odinstalovat a pak připojit USB a jen potvrzovat. Nevím jestli to pomůže, ale co kdyby?   
krizak
Full Member
***

Karma: 1
: 216


301550699
« #10 : November 18, 2009, 21:04:19 »

Ony jsou tiskárny, které jsou podporovány HPLIP plně, jiné vůbec a některé s nutností stažení pluginu. Ta moje je ten poslední případ. Takže po připjení do USB Mandriva tiskárnu najde, nainstaluje, dokonce se tváří, že tiskne, ale z tiskárny nic neleze (před časem se tu objevil podobný problém s jinou tiskárnou). Teprve po stažení a nainstalování pluginu (a vytažení káblíku a opětovném zasunutí) se tisk doopravdy rozběhne. V MDV 2010 RC2 to zafungovalo bez problému, takže v konečné verzi jsem problém neočekával...

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
krizak
Full Member
***

Karma: 1
: 216


301550699
« #11 : November 18, 2009, 23:31:31 »

Takže ještě jeden, a možná docela důležitý, poznatek: Zkusil jsem tiskárnu HP LaserJet P1505 nainstalovat v MDV 2009.1, HPLIP 3.9.2; po zvolení možnosti "Download and install the plug-in from an HP authorized server (recommended) si to řeklo o HESLO SPRÁVCE SYSTÉNU a plugin se po té stáhnul a správně nainstaloval. Obdobně v Ubuntu 9.10 (HPLIP 3.9.8.) jsem v průběhu instalace tiskárny zadával heslo. MDV 2010 (HPLIP 3.9.8.) si o heslo neříká a plugin se nenainstaluje. Že by přece jen nakonec chybka v systému? Pokud ano, předesílám, že mé chabé znalosti angličtiny mi nedovolují ohlásit to do bugzilly  
« : November 18, 2009, 23:34:30 krizak »

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #12 : November 18, 2009, 23:34:29 »

a spouštíš to jako superuživatel root??

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
krizak
Full Member
***

Karma: 1
: 216


301550699
« #13 : November 18, 2009, 23:37:37 »

Ne, protože při předchozí instalaci v MDV 2010 RC2 (a pak v Ubuntu a v MDV 2009.1) si to o heslo řeklo v průběhu instalace samo. Ale zkusím to.

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
krizak
Full Member
***

Karma: 1
: 216


301550699
« #14 : November 18, 2009, 23:43:34 »

[root@localhost krizak]# hp-toolbox
warning: hp-toolbox should not be run as root/superuser.

Nikdy nic nevysvětlujte. Přátelé to nepotřebují a nepřátelé vám stejně neuvěří...
: [1] 2
   |   
 
: