Přihlásit
: 1 [2]
   |   
: Epson S 21 a Mandriva 2010 Spring  ( 7786 )
pert2
Sr. Member
****

Karma: 9
: 291


« #15 : July 14, 2010, 20:13:46 »

[root@localhost ~]#cat /etc/cups/cupsd.conf > /tmp/mujcups
[root@localhost ~]#chmod 777 /tmp/mujcups


Nebo si jako uživatel root otevři nějaký textový editor (třeba kwrite) a otevři ten soubor /etc/cups/cupsd.conf.
z.pepa
Jr. Member
**

Karma: 0
: 78



« #16 : July 14, 2010, 20:39:16 »

Aha oni to jsou 2 příkazy.

Nicméně když to zadám, tak jak jste napsal, neudělá to vůbec nic

Celý výpis (včetně přihlášení se jako root):

[pepa@localhost ~]$ su -
Heslo:
[root@localhost ~]# cat /etc/cups/cupsd.conf > /tmp/mujcups
[root@localhost ~]# chmod 777 /tmp/mujcups
[root@localhost ~]#

Prostě to jen v konsoli poskočí a nabídne opět prázdné bílé okénko...

pert2
Sr. Member
****

Karma: 9
: 291


« #17 : July 14, 2010, 20:57:04 »

Teď se podívej nějakým textovým editorem jako obyčejný uživatel do souboru /tmp/mujcups.
A obsah dej sem.
z.pepa
Jr. Member
**

Karma: 0
: 78



« #18 : July 14, 2010, 21:48:10 »

Je to strašně dlouhé:

LogLevel warn
SystemGroup lpadmin root
Group sys
User lp
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
# Enable printer sharing and shared printers.
Browsing On
BrowseOrder allow,deny
BrowseAllow all
BrowseRemoteProtocols CUPS
BrowseAddress @LOCAL
BrowseLocalProtocols CUPS dnssd
DefaultAuthType Basic
<Location />
  # Allow shared printing and remote administration...
  Order allow,deny
  Allow @LOCAL
</Location>
<Location /admin>
  # Allow remote administration...
  Order allow,deny
  Allow @LOCAL
</Location>
<Location /admin/conf>
  AuthType Default
  Require user @SYSTEM
  # Allow remote access to the configuration files...
  Order allow,deny
  Allow @LOCAL
</Location>
<Policy default>
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job CUPS-Get-Document>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
  </Limit>
  <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
  </Limit>
  <Limit All>
    Order deny,allow
  </Limit>
</Policy>
<Policy authenticated>
  <Limit Create-Job Print-Job Print-URI>
  AuthType Default
  Order deny,allow
</Limit>
  <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job CUPS-Get-Document>
AuthType Default
Require user @OWNER @SYSTEM
Order deny,allow
  </Limit>
  <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
  AuthType Default
  Require user @SYSTEM
  Order deny,allow
    </Limit>
  <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
      </Limit>
  <Limit Cancel-Job CUPS-Authenticate-Job>
      AuthType Default
      Require user @OWNER @SYSTEM
      Order deny,allow
        </Limit>
  <Limit All>
        Order deny,allow
          </Limit>
</Policy>
MaxLogSize 2000000
pert2
Sr. Member
****

Karma: 9
: 291


« #19 : July 14, 2010, 23:08:27 »

Tak nic...
Máš aktualizovaný systém?
V beta-verzích Mandrivy 2010.1 byly právě problémy s tiskem.

Zkusil bych ještě odinstalovat tu tiskárnu a stáhnout originál ovladač odtud:

http://linux.avasys.jp/drivers/lsb/epson-inkjet/stable/RPMS/i486/epson-inkjet-printer-stylus-s21-series-1.0.0-1lsb3.2.i486.rpm

Stažený balíček nainstalovat -stačí na něj poklepat myší a měl by se objevit dialog o instalaci.
A pak znovu tiskárnu nainstalovat a zkusit, jestli jede..

z.pepa
Jr. Member
**

Karma: 0
: 78



« #20 : July 15, 2010, 17:54:38 »

Beta verzi jsem vůbec neměl, stahnul jsem Spring až když tu vyšel článek o uvolněném torrentu.

Odinstaloval jsem a při instalaci z vašeho odkazu mi to zahlásilo toto:

 
Následující balíček má špatnou signaturu:
/home/pepa/.opera/temporary_downloads/epson-inkjet-printer-stylus-s21-series-1.0.0-1lsb3.2.i486.rpm: Neplatný podpis (NOT OK (no key): /home/pepa/.opera/temporary_downloads/epson-inkjet-printer-stylus-s21-series-1.0.0-1lsb3.2.i486.rpm: Hlavička V3 DSA podpis: NOKEY, ID klíče 8aa65d56)


Tiskárna samozřejmě stále nejede.
pert2
Sr. Member
****

Karma: 9
: 291


« #21 : July 15, 2010, 19:37:33 »

Nejprve si ten balíček stáhni a ulož třeba do adresáře /home/pepa, takže celá cesta k souboru bude /home/pepa/epson-inkjet-printer-stylus-s21-series-1.0.0-1lsb3.2.i486.rpm

Pak se v konsole přihlaš jako uživatel root a zkus jej nainstalovat:
[root@localhost ~]#urpmi --no-verify-rpm /home/pepa/epson-inkjet-printer-stylus-s21-series-1.0.0-1lsb3.2.i486.rpm
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #22 : July 15, 2010, 19:42:45 »

  • Nastavit repozitáře a povolit non-free zdroje
  • Zapout a připojit tiskárnu a spustit harddrake2
  • počkat, až se tiskárna identifikuje a stáhnou se ovladače
  • případně restartovat a je to...

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
z.pepa
Jr. Member
**

Karma: 0
: 78



« #23 : July 15, 2010, 20:08:15 »

Pert2:

je tam nějaká chyba...

Výpis z instalace:

1/11: libpostfix1           ##############
     2/11: postfix               ##############
Znovu načítám nastavení postfix: [SELHALO]
Znovu načítám nastavení postfix: [SELHALO]
     3/11: m4                    ##############
     4/11: pax                   ##############
     5/11: make                  ##############
     6/11: libgettextmisc        ##############
     7/11: gettext               ##############
     8/11: lsb-core              ##############
     9/11: glibc_lsb             ##############

Edit:

pokus o novou instalaci

Výpis:

1/11: m4                    ##############
     2/11: pax                   ##############
     3/11: make                  ##############
     4/11: cyrus-sasl            ##############
     5/11: sendmail              ##############
     6/11: libgettextmisc        ##############
     7/11: gettext               ##############
     8/11: lsb-core              ##############
     9/11: glibc_lsb             ##############


Ale tiskárna netiskne.

Mimochodem původně alespoň blikala, teď ani neškytne...
« : July 15, 2010, 20:22:29 z.pepa »
z.pepa
Jr. Member
**

Karma: 0
: 78



« #24 : July 15, 2010, 20:15:36 »

Peťoš: odzkoušeno a výsledek - stále nic, takto se mi to nainstalovalo při prvním spuštění Springu...
pert2
Sr. Member
****

Karma: 9
: 291


« #25 : July 15, 2010, 20:19:02 »

To nic, nainstalovaly se jen balíčky závislé na staženém balíčku epson-inkjet-printer-stylus-s21-series-1.0.0-1lsb3.2.i486.rpm.

Zkus po instalaci nastavit tu tiskárnu.

Škoda že Peťoš neposlal příspěvek dřív, nastavení zdrojů "non-free" je dobrý nápad.
Jaké máš nastavené zdroje software?

z.pepa
Jr. Member
**

Karma: 0
: 78



« #26 : July 15, 2010, 20:26:05 »

Mám prakticky všechny co tam jsou, čili "Contrib", "Main" a "Non-free"

Tiskárnu nastavuji po každé nové instalaci a odesílám zkušební tisk 
z.pepa
Jr. Member
**

Karma: 0
: 78



« #27 : July 19, 2010, 21:37:44 »

Tak jsem to vyřešil - nainstaloval jsem starou 2010, až budou ve Springu vychytané mouchy, možná se k němu vrátím, ale spíš si počkám na 2011.

Díky všem za pomoc
: 1 [2]
   |   
 
: