Přihlásit
: [1] 2
   |   
: OpenOffice - síťový disk  ( 9535 )
George111
Full Member
***

Karma: 0
: 118



« : August 25, 2010, 12:15:56 »

Zdravím,
problém je následující. V Dolphinu si přes volbu "Síť -- Přidat síťovou složku" namapuji adresář, který je sdílený na Windows serveru. Po zadání jména a heslo co mě Dolphin vyzve se bez problémů do adresáře dostanu a lze se soubory i adresáři manipulovat. Ovšem když chci otevřít např. excelový soubor přímo z tohoto síťového disku tak to OpenCalc neotevře. Prostě jen začne nabíhat a vzápětí se zavře. Když ovšem daný soubor překopíruji na příklad do svého lokálního /home tak OpenCalc normálně tento soubor otevře a lze s ním dělat. Právy na příslušném síťovém disku to určitě není. Je to můj síťový home a mám zde full access. Ve Win tento soubor normálně přímo ze síťového disku otevřu.

Pls, nějaká rada ? Díky.

Díky, díky za odpovědi. Používám MND Free 2010.1 64bit, KDE 4.4. (desktop) a MND Free 2010.1 32b, Gnome 2.30.0 (NB).
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #1 : August 25, 2010, 12:26:53 »

Zkus místo mapování přes Dolphin použít MCC > Sdílení v síti....
Zkus ale pohledat tady na foru, mám pocit, že se to tu už jednou někde řešilo.

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
George111
Full Member
***

Karma: 0
: 118



« #2 : August 25, 2010, 12:41:28 »

to by možná byla cesta, ale když spustím v mcc přístup pomocí samby na windows disk tak tam je akorát volba "Vyhledat servery" tato volba mi prohledá pouze lokální subnet sítě a tím to skončí. Lze někde v gui přímo zadat název serveru na který chci přistupovat, nebo budu muset nastudovat sambu v CLI ? Server leží přes x subnetů daleko v síti.

díky

Díky, díky za odpovědi. Používám MND Free 2010.1 64bit, KDE 4.4. (desktop) a MND Free 2010.1 32b, Gnome 2.30.0 (NB).
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #3 : August 25, 2010, 12:43:54 »

Aha, tak to je jiná. V tom případě ještě můžeš zkusit nástroj gigolo -- je v repozitářích. Připojí se k čemukoli. Přehledné, jasné GUI. Zkus.
Ale hlavně bych pohledal tady na foru, zda-li není fakt chyba v OOo+samba. Vím, že se to tu řešilo. Jak praví nesmrtelný klasik Cimrman:
Hledej, šmudlo

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
George111
Full Member
***

Karma: 0
: 118



« #4 : August 25, 2010, 13:25:19 »

OK. díky. Zkusím. Dám sem pak vědět.

Díky, díky za odpovědi. Používám MND Free 2010.1 64bit, KDE 4.4. (desktop) a MND Free 2010.1 32b, Gnome 2.30.0 (NB).
George111
Full Member
***

Karma: 0
: 118



« #5 : August 25, 2010, 14:05:25 »

tak Gigolo připojí do uživatelovo /home pod adresář .gvfs sdílený adresář na windows serveru a normálně lze s takovýmto adresářem pracovat v Dolphinu a hlavně lze přímo z disku otevírat soubory pomocí OOP. jenom je to porod, protože program je ve Finštině, nebo bůhví jakém jazyku :-( Teď jenom vymyslet zautomatizování procesu připojování tohoto disku přes Gigolo. Zkusím nastudovat parametry příkazové řádky tohoto SW.
Problém to sice neřeší, ale obchází, nicméně díky za řešení :-) :-) :-)

Díky, díky za odpovědi. Používám MND Free 2010.1 64bit, KDE 4.4. (desktop) a MND Free 2010.1 32b, Gnome 2.30.0 (NB).
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #6 : August 25, 2010, 14:16:27 »

Finsky? Tohle jsem už taky někde řešil = (pohledej tady na foru). 

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
b3da
Sr. Member
****

Karma: 7
: 385


« #7 : August 25, 2010, 16:00:11 »

Prostě jen začne nabíhat a vzápětí se zavře. Když ovšem daný soubor překopíruji na příklad do svého lokálního /home tak OpenCalc normálně tento soubor otevře a lze s ním dělat. Právy na příslušném síťovém disku to určitě není. Je to můj síťový home a mám zde full access. Ve Win tento soubor normálně přímo ze síťového disku otevřu.
Pls, nějaká rada ? Díky.
Jsem na tom stejně, jen jsem to zatím neřešil ...
Určitě je to problém Ooo, protože jiné soubory (txt, jpg ... ) otevřu bez problémů. Druhá strana problému bude buď samba, nebo kde4. V 2008 s kde3 otevřu i soubory Ooo.

Zkus ale pohledat tady na foru, mám pocit, že se to tu už jednou někde řešilo.
Bohužel jsem nic nenašel.
George111
Full Member
***

Karma: 0
: 118



« #8 : August 25, 2010, 18:36:01 »

taky si myslím, že bude problém někde v Sambě potažmo v její implementaci v Dolphinu jakou součásti KDE 4. Zkusím to nějak obejít přes CLI. ten program co doporučil Peťoš je docela neohrabaný, když si člověk chce třeba udělat zástupce jednotlivých vnořených adresářů vzdáleného disku. už to vidím, že z toho bude "pěkný" přihlašovací skript, který budu muset nějak sbastlit 
Kdyby se do toho chtěl taky někdo pustit tak budu rád.

zatím zdar.

Díky, díky za odpovědi. Používám MND Free 2010.1 64bit, KDE 4.4. (desktop) a MND Free 2010.1 32b, Gnome 2.30.0 (NB).
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #9 : August 25, 2010, 18:38:18 »

Pak je možnost použít starý dobrý /etc/fstab, že ano

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
Ivan Bibr
Administrator
Hero Member
*****

Karma: 52
: 3 298



« #10 : August 25, 2010, 19:32:58 »

Asi bych šel cestou definice sdíleného disku ve fstabu. Tady na fóru OOo radí použít mount option nobrl.

George111
Full Member
***

Karma: 0
: 118



« #11 : August 26, 2010, 09:54:40 »

tak jsem téměř u cíle. sdílený disk připojím příkazem

mount -t cifs -o user=domena/login,password=heslo,uid=500,gid=500,nobrl //serverWIN/sdilena_slozka /home/user/adresar

Všechno "funguje" až na jednu malou maličkost. Jakmile je v názvu adresáře nebo souboru česká diakritika tak je to konec a v Dolphinu mi to hlásí, že takový adresář/soubor pochopitelně nelze otevřít  Neporadíte někdo jak tohle ještě vyřešit ?

Díky, díky moc.

Díky, díky za odpovědi. Používám MND Free 2010.1 64bit, KDE 4.4. (desktop) a MND Free 2010.1 32b, Gnome 2.30.0 (NB).
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #12 : August 26, 2010, 09:58:48 »

k tomu, co ještě máš, dopsat kodování serveru
:
iocharset=kodovani
kde kodovani bude samozřejmě správné označení

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
George111
Full Member
***

Karma: 0
: 118



« #13 : August 26, 2010, 11:49:23 »

kupodivu zabral parametr iocharset=utf8, byť jako kódování v Evolution (připojuje se na ten samý server WIN Exchange) musím mít kódovou stránku Windows-1251, jinak mi chodí v poště čínský čaj :-)

takže problém s OOo vyřešen, teď bych nicméně potřeboval jako tento mount příkaz spouštět automaticky po startu jako běžný uživatel a ne jako root......vím co mi odpovíte....bylo zde již řešeno....hledej šmudlo :-))) tak už jdu na to :-)

Jen poznámka na okraj...včera jsem četl flame o tom proč se na desktopech pro obyč usery Linux neprosazuje - zde je zářná odpověď, který user by byl toto ochoten absolovat asi tak 1% nadšenců jako jsme my :-)

Díky, díky za odpovědi. Používám MND Free 2010.1 64bit, KDE 4.4. (desktop) a MND Free 2010.1 32b, Gnome 2.30.0 (NB).
Ivan Bibr
Administrator
Hero Member
*****

Karma: 52
: 3 298



« #14 : August 26, 2010, 12:49:58 »

kupodivu zabral parametr iocharset=utf8, byť jako kódování v Evolution (připojuje se na ten samý server WIN Exchange) musím mít kódovou stránku Windows-1251, jinak mi chodí v poště čínský čaj :-)

Protože Exchange je jiná úplně služba než sdílení souborů (Samba), že jo ...

: [1] 2
   |   
 
: