Přihlásit
: [1]
   |   
: geany a závislosti  ( 3144 )
tomyp
Sr. Member
****

Karma: 5
: 310


Smrt a daně máte jisté. Daně ovšem jistější.

375195726
« : September 22, 2010, 21:48:02 »

tak jsem si chtěl zase trochu potrenovat programování a nainstaloval jsem si balíček geany (doporučovaný Peťošem) a zjistil jsem, že má nedokonalé závislosti. po instalaci je nutné ručně doinstalovat xterm a gcc překladač. 

MDV 2010.1  KDE 4.4.3
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #1 : September 22, 2010, 21:54:49 »

Odkud jsi to instaloval? Z mého repa, nebo oficiální?

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
tomyp
Sr. Member
****

Karma: 5
: 310


Smrt a daně máte jisté. Daně ovšem jistější.

375195726
« #2 : September 22, 2010, 22:01:12 »

ja si neuvědomil, že ty ho máš v repu taky. takže v tomto případě je to tvůj balíček.

MDV 2010.1  KDE 4.4.3
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #3 : September 22, 2010, 22:09:15 »

ok, opravím během několika minut.

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #4 : September 22, 2010, 22:35:08 »

ok, opravím během několika minut.
Vydána aktualizace, která myslím všechno řeší, jen prosím počkejte, než se vše nahraje na server.

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #5 : September 24, 2010, 15:56:44 »

Uvažoval jsem nad tím a původní chování a závislosti byly správné -- geany je textový editor s možností volání překladu, debuggeru, překladu do LaTeXu a dalších. Pokud chcete tyto vlastnosti používat, je nutné je nainstalovat zvlášť. Kdyby měl geany instalovat všechny další programy, které je možné z něj volat (pozor, píšu JE MOZNE volat, nikoli že na nich běh geany závisí), tak to bude opravdu dlouhý seznam a bude s textovým editorem staženo i poměrně velké množství dalších dat (celý GCC, TeX, LaTeX... celkem na 500 MB).

Geany je textový editor a jako takový má všechny závislosti v pořádku. Pokud chcete překládat, tak celkem logicky musíte nainstalovat i překladač.

Vydána oprava s revertováním změn.

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
tomyp
Sr. Member
****

Karma: 5
: 310


Smrt a daně máte jisté. Daně ovšem jistější.

375195726
« #6 : September 24, 2010, 19:24:19 »

no to asi ano, ovšem jako terminál odmítá použít něco jiného než xterm

MDV 2010.1  KDE 4.4.3
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #7 : September 24, 2010, 19:29:29 »

Ano, ten tam ovšem zůstal

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #8 : September 26, 2010, 16:56:51 »

no to asi ano, ovšem jako terminál odmítá použít něco jiného než xterm
Stačí změnit volbu terminál z xterm na cokoli jiného v nastavení v Upravit > Nastavení > Terminál

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
tomyp
Sr. Member
****

Karma: 5
: 310


Smrt a daně máte jisté. Daně ovšem jistější.

375195726
« #9 : September 27, 2010, 08:35:11 »

po instalaci bez těch závislostí je tam /bin/bash, ale při překladu to zásadně řve, že chce xterm a program se nepřeloží. a nebo něco dělám blbě? 

MDV 2010.1  KDE 4.4.3
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #10 : September 27, 2010, 10:23:33 »

po instalaci bez těch závislostí je tam /bin/bash, ale při překladu to zásadně řve, že chce xterm a program se nepřeloží. a nebo něco dělám blbě? 
musí tam být jméno tvého emulátoru terminálu:
xterm
terminal
lxterminal
Eterm
${Terminal pro KDE}
${Terminal pro GNOME}

/bin/bash je něco naprosto jiného...

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
: [1]
   |   
 
: