Přihlásit
: [1] 2
   |   
: Googleearth nemůžu spustit  ( 15685 )
sešit
Jr. Member
**

Karma: -12
: 54


« : January 16, 2011, 12:30:06 »

Pomoci balíčkovače jsem si nainstaloval balík googleearth, i závislosti. Celkem tyto balíky:
- curl-7.20.1-2mdv2010.1.i586
- googleearth-5.2.1.1547-1plf2010.1.i586
- libcurl4-7.20.1-2mdv2010.1.i586
- libldap2.4_2-2.4.22-2mdv2010.1.i586
- libssh2_1-1.2.5-1mdv2010.1.i586
- rootcerts-20100408.00-1mdv2010.1.i586
Potom jsem chtěl tuto aplikaci spustit, ale nejde to. Prohledal jsem celou nabídku, včetně podnabídky "sítě", ale nikde nemám položku googleearth, ani nic podobného. Potom jsem to zkusil spustit příkazem, ale žádný příkaz nefunguje. Nefungují ani tyto příkazy:
:
googleearth
:
google-earth
:
/usr/bin/googleearth
, ani žádné podobné. Všechno to hlásí command not found. Znovu jsem se podíval do balíčkovače a balíčkovač tvrdí, že všechny ty balíčky mám nainstalované. Podíval jsem se na podrobnosti balíčku googleearth-5.2.1.1547-1plf2010.1.i586, jaké jsou nainstalované soubory a ‎/usr/bin/googleearth je tam vypsaný. Když jsem potom zadal
:
ls /usr/bin
, tak žádný googleearth, ani nic podobného tam není. Přitom všechny balíky musím mít nainstalované, protože jsem kontroloval, co balíčkovač dělá: Jak jsem instaloval balík googleearth a další závislé, tak jsem se díval na hlášení "stahuji balík..." "instaluji balík..." a podle toho se mi stáhlo i nainstalovalo všechno, co jsem vypsal.
sešit
Jr. Member
**

Karma: -12
: 54


« #1 : January 16, 2011, 13:42:49 »

Potom jsem vyzkoušel googleearth v druhém počítači, ve kterém mám ještě starší Mandrivu 2008.0 32 bitů, a tentokrát  jsem se rozhodl pro možnost aplikaci nainstalovat bez balíku. Ze stránek http://www.google.com/intl/cs/earth/download/ge/agree.html jsem si stáhnul soubor GoogleEarthLinux.bin 32 MB. Je to verze 6.0 beta. Stažený soubor jsem nastavil na spustitelný. Potom jsem ten soubor spustil z konzole a tím ho instaloval: Hlášení:
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 6.0.1.2032.............................................................................................
This version of Google Earth requires LSB 4.0 support which you
do not seem to have.
loki_setup: Suspect size value for option option
loki_setup: Suspect size value for option option
Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
. Nainstalovalo se to do ~/google-earth. Přešel jsem do toho adresáře a zadal
:
./googleearth-bin
Ale zase to nefunguje. Píše to, že googleearth-bin není souborem ani adresářem. Přitom tam ten soubor mám. Překlep jsem taky nemohl udělat, protože jsem příkaz zadal potom znovu ale schválně jenom
:
./googleearth-b
a použil klávesu Tab, která mi název dopsala. A kdyby jsem měl překlep, nebo kdyby jsem ten soubor neměl, tak mi to ani ta klávesa nedopíše. Ani příkaz s plnou cestou
:
/home/uzivatel/google-earth/googleearth-bin
nepomůže. A abych se přesvědčil, že jsem neudělal překlep, zkusil jsem zase příkaz zadat znovu, ale tentokrát zase jenom
:
/home/uzivatel/google-earth/googleearth-b
a klávesu Tab a ta to dopsala, takže podle toho soubor existuje. Ale když jsem potvrdil Enter, tak to zase lže, že /home/uzivatel/google-earth/googleearth-bin není souborem ani adresářem. A přitom příkaz
:
ls /home/uzivatel/google-earth
, který mi vypsal soubory, vypsal i ten soubor, googleearth-bin, o kterém příkaz
:
/home/uzivatel/google-earth/googleearth-bin
, lže, že není souborem ani adresářem. Potom jsem zkusil zadat
:
file -k googleearth-bin
a to netvrdí, že soubor neexistuje. To mi vypisuje
googleearth-bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.15, dynamically linked (uses shared libs), stripped
tajgr
Newbie
*

Karma: 0
: 46


« #2 : January 17, 2011, 19:28:43 »

Neobjevila se při instalaci tahle hláška?
:
/usr/local/bin/googleearth: řádek 49: /opt/google-earth/googleearth-bin: Adresář nebo soubor neexistuje
/usr/local/bin/googleearth: řádek 49: /opt/google-earth/googleearth-bin: Úspěch

pak pomůže tenhle topic: http://forum.mandrivalinux.cz/index.php?topic=12216.msg80521#msg80521

Jinak, ve zdrojích je pokud vím jen skript, který stáhne a nainstaluje binárku. V poslední době prý nefunguje.
Hobil
Hero Member
*****

Karma: 58
: 4 006


« #3 : January 17, 2011, 21:12:00 »

pro osobni i pracovni ucely vyuzivam portal Ceskeho ustavu zememericskeho a katastralniho (http://geoportal.cuzk.cz), lze tam nastavit (samozrejme jen pro nasi republiku) ruzne zobrazeni od orthofota pres ruzna meritka map po ZABAGED (statni mapove dilo, nejpodrobnejsi, co je vubec k dispozici), nebo i katastralni mapy vcetne cisel parcel atd atd.
V levem sloupci vyhledavani a zakladni nastaveni, v pravem sloupci vyber polozek v prislusnem zobrazeni, siroke okraje lze skryt (to jen par poznamek pro lamy  )
Doporucuju.
H.

Benzínem se nemá hasit ohniště
teď už je to jedno, ale pro příště... (K.P.)
tajgr
Newbie
*

Karma: 0
: 46


« #4 : January 17, 2011, 21:27:01 »

Dík za typ, akorát mě víc jak obsah webu, potěšil ten pohled na mé oblíbené a také rodné město .
sešit
Jr. Member
**

Karma: -12
: 54


« #5 : January 19, 2011, 18:46:24 »

Neobjevila se při instalaci tahle hláška? usr/local/bin/googleearth: řádek 49: /opt/google-earth/googleearth-bin: Adresář nebo soubor neexistuje
/usr/local/bin/googleearth: řádek 49: /opt/google-earth/googleearth-bin: Úspěch
Ano, objevila, ale s tím rozdílem, že místo /usr/local/bin to používalo /home/uzivatel/google-earth. Přesto hláška zní divně.
Nakonec jsem ten Googleearth z toho druhého počítače (ve kterém je Mandrivalinux 2008.0) odinstaloval a stažený soubor smazal. Stáhnul ho jsem znovu, tentokrát ze http://download.chip.eu/cz/Google-Earth-Linux_387113.html. Soubor se jmenuje GoogleEarthLinux50.bin a má 24 MB. Nainstaloval jsem ho zase do ~/google-earth (výchozí nastavení). Instaloval jsem ho a jak se mě to ptalo, jestli chci aplikaci spustit, tak jsem hned zvolil start. Okno Googleearthu se otevřelo a hned zase zmizelo. Tady je výpis z konzole.
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.0.11337.1968..............................................................
loki_setup: Suspect size value for option option
loki_setup: Suspect size value for option option
loki_setup: Suspect size value for option option
Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
Warning: Unable to create prefs directory /home/uzivatel/.googleearth'. Soubor již existuje.
./googleearth-bin: symbol lookup error: /usr/lib/libssl.so.0.9.8: undefined symbol: EVP_camellia_128_cbc
V odkazu na tam ten topic jsem se dočetl, že by mělo pomoct doinstalovat balík lsb-core, tak jsem to udělal, včetně závislostí. Nepomohlo to ale, stále Googleearth nemůžu spustit a chybové hlášení mám stejné.
Ještě bych něco řekl o balíku googleearth: Mluvím teď o Mandrivalinuxu 2008.0. Dříve byl v repozitáři PLF-nonfree release a měl jsem ho i ve správci balíčků. Potom mi ze správce balíčků googleearth zmizel, ikdyž jsem zdroj PLF-nonfree release neodebíral. Když jsem se potom podíval na internet do tohoto repozitáře, balík googleearth už tam taky nebyl. To je poprve, co se mi stalo, že z repozitářů mizí balíčky, což by se nemělo stát. Jinak balík googleearth už stejně nepoužívám, raději si stahuji přímo binárku. Četl jsem, že balík googleearth stejně žádnou aplikaci neobsahuje, obsahuje jenom skript pro stažení te aplikace. Proto je ten balík podle mě k ničemu.
Hobil
Hero Member
*****

Karma: 58
: 4 006


« #6 : January 19, 2011, 19:36:24 »

... Jinak balík googleearth už stejně nepoužívám, raději si stahuji přímo binárku. Četl jsem, že balík googleearth stejně žádnou aplikaci neobsahuje, obsahuje jenom skript pro stažení te aplikace. Proto je ten balík podle mě k ničemu.
Ne tak docela. Skripty obsahuji nejen prikazy pro stazeni, ale i vlastni instalaci, pridani do menu, zaznam do databaze rpm pro snadnou pozdejsi odinstalaci, nastaveni pro pripadne aktualizace a mozna i dalsi veci.
Samozrejme pokud je vlastni aplikace spatna, zadny skript to dohnat nemuze.

Nekdy si ty skripty projdi, nez budes shazovat praci druhych.

H.

Benzínem se nemá hasit ohniště
teď už je to jedno, ale pro příště... (K.P.)
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #7 : January 19, 2011, 22:30:38 »

Mohlo by pomoct smazani souboru /opt/google-erath/libcrypto.so.0.9.8
Myslím, že ne, Time

To, že je nějaký symbol nedefeinovaný v knihovně neopravíš tím, že smažeš danou knihovnu. GE je linkován staticky (sic!), takže pokud smažeš knihovnu, nespustíš to vůbec.

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
jentzek
Sr. Member
****

Karma: 12
: 305



« #8 : January 19, 2011, 23:20:05 »

Myslím, že ne, Time

To, že je nějaký symbol nedefeinovaný v knihovně neopravíš tím, že smažeš danou knihovnu. GE je linkován staticky (sic!), takže pokud smažeš knihovnu, nespustíš to vůbec.
Jo to je dalsi vec, vidis ...
Nebyl sem si tim moc jistej, navic ja tam tu knihovnu nemam, tak sem prispevek radeji smazl. To si byl teda setsakramentsky rychlej Radili to po ruznych forech (suse), napadlo me, ze to zabere.
tajgr
Newbie
*

Karma: 0
: 46


« #9 : January 20, 2011, 00:32:26 »

Ano, objevila, ale s tím rozdílem, že místo /usr/local/bin to používalo /home/uzivatel/google-earth. Přesto hláška zní divně.
...
V odkazu na tam ten topic jsem se dočetl, že by mělo pomoct doinstalovat balík lsb-core, tak jsem to udělal, včetně závislostí. Nepomohlo to ale, stále Googleearth nemůžu spustit a chybové hlášení mám stejné.
Ten typ s tím balíkem mám od tud: http://www.google.com/support/forum/p/earth/thread?tid=144696eab7d5a9c7&hl=en bude tam lepší info. Dál, já instaloval s právy roota, proto ta jiná cesta. Asi je to jedno, ale za pokus by to možná stálo.
Googleearth měl v poslední době ještě jeden problém. Je to popsáno a vyřešeno tady: http://forum.mandrivalinux.cz/index.php?topic=12322.msg80176#msg80176. Pravda ale je, že se to týkalo verze 5 a jak je to u v6 to nevím.
sešit
Jr. Member
**

Karma: -12
: 54


« #10 : January 20, 2011, 18:10:16 »

To, jak jsem říkal, že balík googleearth je k ničemu, tím jsem nechtěl shazovat práci těch, co ten balík vyrábí, spíš jsem tím myslel, že pro mě není tak důležitý, protože Googleearth jsem si už zvykl stahovat přímo ze stránek, kde je ta binárka, takže mi nemusí vadit, že ten balík ze zdrojů softwaru zmizel. Jenom nechápu, jak mohl zmizet z repozitářů balík, který tam už byl.
Ten problém s nedefinovanou knihovnou mám Googleearth verzi 5. Tu hlášku,
/home/uzivatel/google-earth/googleearth-bin: Adresář nebo soubor neexistuje
/usr/local/bin/googleearth: řádek 49: /home/uzivatel/google-earth/googleearth-bin: Úspěch
jsem měl u verze 6. Protože už šestku nemám, tak toto hlášení už nemám. Používám teď pětku.
Podle odkazované diskuze, týkající se pětky jsem to řešil taky tak, že jsem do souboru /home/uzivatel/.config/Google/GoogleEarthPlus.conf připsal na konec řádek
enableTips=false
. Nepomáhá to ale. Pořád to nejde spustit a pořád to hlásí ten problém s nedefinovanou knihovnou:
./googleearth-bin: symbol lookup error: /usr/lib/libssl.so.0.9.8: undefined symbol: EVP_camellia_128_cbc
sešit
Jr. Member
**

Karma: -12
: 54


« #11 : January 20, 2011, 18:46:54 »

Ve vlákně http://forum.mandrivalinux.cz/index.php?topic=12322.msg80176#msg80176 se píše:
stahni si GE odtud: ​http://www.google.com/earth/download/thanks.html#os=linux
a nainstaluj pomocí tohoto návodu: http://wiki.mandrivalinux.cz/instalace-programu-run
Tak jsem zase odinstaloval GE, který mám a stáhnul jsem si to, co se v tam te diskuzi píše. Soubor se jmenuje GoogleEarthLinux.bin a má 32 MB. Dal jsem oprávnění spouštět a potom jsem začal instalovat a tady je výpis z konzole.
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 6.0.1.2032.............................................................................................
loki_setup: Suspect size value for option option
loki_setup: Suspect size value for option option
loki_setup: Suspect size value for option option
Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
Při instalaci jsem zvolil instalovat do domácího adresáře. Potom jsem dal start. Otevřelo se okno aplikace.  Zeptalo se mě to, jestli se chci přepnout do režimu direct X a zmáčknul jsem ano. V tom okno aplikace zmizelo a výpis je takový:
Google Earth has caught signal 11.
We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:
/home/uzivatel/.googleearth/crashlogs/crashlog-4d3863e7.txt
Please include this file if you submit a bug report to Google.
Zkusil jsem potom spustit Googleearth bez directu X a ani to nefunguje. Výpis z konzole:
Google Earth has caught signal 11.
We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:
/home/uzivatel/.googleearth/crashlogs/crashlog-4d3863e7.txt
Please include this file if you submit a bug report to Google.
Já nevím, co si mám o tom Googleearthu myslet. Už jsem stáhnul hodně Googleearthů a ani jeden mi nefunguje.
tajgr
Newbie
*

Karma: 0
: 46


« #12 : January 20, 2011, 22:46:22 »

./googleearth-bin: symbol lookup error: /usr/lib/libssl.so.0.9.8: undefined symbol: EVP_camellia_128_cbc

zeptal jsem se Googla a on mi dal hned několik možností... dokonce i česky mluvil. http://senkjakub.blogspot.com/2009/02/problem-s-instalaci-google-earth-5.html 
sešit
Jr. Member
**

Karma: -12
: 54


« #13 : January 21, 2011, 19:19:20 »

Tak jsem si odinstaloval Googleearth, který mám a nainstaloval jsem si znovu tu pětku, která měla problém s nedefinovaným symbolem v knihovně a začal jsem to řešit podle toho článku, z toho odkazu. V adresáři ~/google-earth jsem vyhledal knihovnu libcrypto.so.0.9.8 a tu jsem zkusil přejmenovat na venlibcrypto.so.0.9.8. Potom jsem zkusil spustit Googleearth znovu, ale zase nefunguje. Otevřel se jenom úvodní obraz, nic víc. Konzole vypisuje toto hlášení:
Warning: Unable to create prefs directory '/home/uzivatel/.googleearth'. Soubor již existuje.
Což by nemělo vadit. Nic víc se mi v Konzoli nepíše, dokonce mi to nevrací ani výzvu příkazového řádku. Jenom to čeká třeba i půl hodiny a nic se neděje. Nakonec jsem GE ukončil klávesou CTRL C. Zkusil jsem přejmenovat adresář ~/.googleearth, o kterém se mi psalo, že existuje a zkusil pustit GE znovu. Spouštělo se to pomalu, ale už je vidět pokrok, protože už to konečně jede. Ale jede to divně. Obraz Země a ovládací prvky kolem ní se neustále dokola vykresluje a zase mizí a celá aplikace je neovladatelná. Žádné hlášení v konzoli.
sešit
Jr. Member
**

Karma: -12
: 54


« #14 : January 22, 2011, 12:29:06 »

Znovu jsem ten Googleearth pětku zkusil pustit a zase to blbne. Obraz Země i ovládací prvky neustále blikají a aplikace se nedá vůbec ovládat. Dokonce se mi začala ztrácet myš, takže jsem nemohl aplikaci ani ukončit a celý počítač se stal neovladfatelným. Chová se to, jak zavirované. Nakonec se mi povedlo najet na okno Konzole, ze kterého jsem to měl spuštěné a mohl použít CTRL C. To není možné, jak se ta aplikace chová. Že bych se nevešel do požadavků? O Googleearthu se píšou požadavky takové:
Minimum:
    * Kernel: 2.4 or later
    * glibc: 2.3.2 w/ NPTL or later
    * XFree86-4.0 or x.org R6.7 or later
    * CPU: Pentium 3, 500Mhz
    * System Memory (RAM): 256MB
    * Hard Disk: 400MB free space
    * Network Speed: 128 Kbits/sec
    * Graphics Card: DirectX9 and 3D capable with 64MB of VRAM
    * Screen: 1024x768, "16-bit High Color" screen
Recommended:
    * Kernel 2.6 or later
    * glibc 2.3.5 w/ NPTL or later
    * x.org R6.7 or later
    * System Memory (RAM): 512MB
    * Hard Disk: 2GB free space
    * Network Speed: 768 Kbits/sec
    * Graphics Card: DirectX9 and 3D capable with 256MB of VRAM
    * Screen: 1280x1024, 32 bit color
Co mám já:
    * Kernel 2.6.22.9-desktop-1mdv
    * glibc 2.6.1-4mdv2008.0
    * x11-server-xorg 1.3.0.0-24mdv2008.0
    * CPU: AMD Sempron 64 3200 Box AM2
    * Volné místo na disku více než 50 GB
    * Paměť RAM 1 GB
    * Rychlost internetu 4 Mb/sec
    * Grafická karta nevím, ale základní desku mám MSI K9AG NEO-F s.AM2 AMD
    * Obrazovka: BENQ 15"LCD,FP51G+,250cd/m2,400:1,8ms-detail
Začínám pochybovat o tom, že Googleearth může někdy fungovat.
« : January 22, 2011, 12:30:37 sešit »
: [1] 2
   |   
 
: