Přihlásit
: [1]
   |   
: Aktualizace pomocí urpmi --auto-select  ( 7982 )
medulin
Sr. Member
****

Karma: 0
: 283


« : April 22, 2011, 18:58:37 »

Ahoj, používal jsem pro testovaní cooker verzi a měl jsem nastavené zdroje na cooker. Jenže asi po vydání verze 2010.2 jsem zůstal na této verzi a už cookera nemám
:
  cat /etc/mandrake-release
Mandriva Linux release 2010.2 (Official) for i586
Doufal jsem že budu mít pořád cookera. Vymazal jsem tedy zdroje a nastavil pomocí http://easyurpmi.zarb.org nové zdroje na cooker verzi. A dále postupoval podle návodu zde: http://wiki.mandrivalinux.cz/system:aktualizace:upgrade_repozitare.
Po zadání příkazu
:
  urpmi --auto-select
jsem ze dozvěděl:
:
  odebrání balíčku basesystem-minimal-2010.0-2mdv2010.1.i586 naruší funkčnost vašeho systému
Instalace nemůže pokračovat, protože následující balíčky musí
být odstraněny, aby bylo možné jiné aktualizovat:
basesystem-2010.0-2mdv2010.1.i586
 (z důvodu chybějícího basesystem-minimal)
basesystem-minimal-2010.0-2mdv2010.1.i586
 (z důvodu chybějícího rpm)
codeina-0.10.7-1mdv2010.1.noarch
 (z důvodu chybějícího gurpmi)
cups-1.4.3-3.1mdv2010.1.i586
 (z důvodu nesplněného cups-common >= 1.4.3-3.1mdv2010.1)
cups-common-1.4.3-3.1mdv2010.1.i586
 (z důvodu nesplněného rpm >= 3.0.4-6mdk)
drakconf-12.19-1mdv2010.1.noarch
 (z důvodu chybějícího drakx-kbd-mouse-x11,
  z důvodu nesplněného drakxtools >= 11.64,
  z důvodu nesplněného harddrake-ui > 10-12mdk,
  z důvodu chybějícího drakx-net,
  z důvodu nesplněného userdrake >= 1.2-1mdk)
drakfax-0.17.3-3mdv2010.1.noarch
 (z důvodu nesplněného drakxtools >= 10-0.9mdk)
drakguard-0.7.7-1mdv2010.1.noarch
 (z důvodu nesplněného drakxtools >= 10.22,
  z důvodu nesplněného drakx-net >= 0.41)
drakmenustyle-0.14.1-3mdv2010.1.noarch
 (z důvodu nesplněného drakxtools >= 10.4.53-1mdv2007.0)
draksnapshot-0.20.3-1mdv2010.1.noarch
 (z důvodu nesplněného drakxtools >= 10.59)
drakstats-0.23.2-1mdv2010.1.noarch
 (z důvodu chybějícího perl-URPM,
  z důvodu chybějícího perl(URPM))
drakwizard-3.7.4-1mdv2010.1.noarch
 (z důvodu nesplněného drakxtools >= 9.1-0.4mdk)
drakx-kbd-mouse-x11-0.90-1mdv2010.1.i586
 (z důvodu nesplněného drakxtools-curses >= 12.40)
drakx-net-0.90-1mdv2010.1.noarch
 (z důvodu nesplněného drakx-net-text == 0.90,
  z důvodu nesplněného drakxtools >= 12.36,
  z důvodu nesplněného libdrakx-net == 0.90)
drakx-net-text-0.90-1mdv2010.1.noarch
 (z důvodu nesplněného drakxtools-curses >= 12.36,
  z důvodu nesplněného libdrakx-net == 0.90)
drakxtools-13.35-1mdv2010.1.i586
 (z důvodu nesplněného drakxtools-curses == 13.35-1mdv2010.1,
  z důvodu chybějícího drakx-net)
drakxtools-backend-13.35-1mdv2010.1.i586
 (z důvodu chybějícího perl-suid,
  z důvodu chybějícího perl(Xconfig::resolution_and_depth))
drakxtools-curses-13.35-1mdv2010.1.i586
 (z důvodu nesplněného urpmi >= 4.8.23)
eee-control-0.9.4-4.1mdv2010.1.i586
 (z důvodu nesplněného python < 2.7)
firefox-cs-3.6.16-0.1mdv2010.2.i586
 (z důvodu chybějícího locales-cs)
gdm-2.30.2-12.1mdv2010.2.i586
 (z důvodu chybějícího drakx-kbd-mouse-x11)
genhdlist2-5.9-3mdv2010.1.i586
 (z důvodu chybějícího perl(URPM))
gstreamer0.10-python-0.10.18-1mdv2010.1.i586
 (z důvodu nesplněného python < 2.7)
gtk+2.0-2.20.1-1mdv2010.1.i586
 (z důvodu konfliktů s gdk-pixbuf2.0-2.22.1-3-mdv2011.0.i586)
gurpmi-6.38-1mdv2010.1.noarch
 (z důvodu nesplněného urpmi >= 6.38-1mdv2010.1)
gutenprint-cups-5.2.5-1mdv2010.1.i586
 (z důvodu nesplněného cups >= 1.1)
harddrake-13.35-1mdv2010.1.i586
 (z důvodu nesplněného drakxtools-curses == 13.35-1mdv2010.1,
  z důvodu chybějícího drakx-kbd-mouse-x11,
  z důvodu chybějícího perl(Xconfig::card),
  z důvodu chybějícího libdrakx-net)
harddrake-ui-13.35-1mdv2010.1.i586
 (z důvodu chybějícího drakx-kbd-mouse-x11,
  z důvodu nesplněného drakxtools == 13.35-1mdv2010.1,
  z důvodu chybějícího libdrakx-net)
hplip-3.10.2-5.1mdv2010.2.i586
 (z důvodu nesplněného cupsddk-drivers >= 1.2.3-2mdv,
  z důvodu chybějícího cups)
hplip-gui-3.10.2-5.1mdv2010.2.i586
 (z důvodu nesplněného hplip == 3.10.2-5.1mdv2010.2)
libdrakx-net-0.90-1mdv2010.1.noarch
 (z důvodu chybějícího perl(Xconfig::resolution_and_depth))
libhpip0-3.10.2-5.1mdv2010.2.i586
 (z důvodu chybějícího libnetsnmp.so.20)
locales-2.12.1-1mdv2011.0.i586
 (z důvodu chybějícího rpm[*])
locales-cs-2.12.1-1mdv2011.0.i586
 (z důvodu nesplněného locales == 2.12.1-1mdv2011.0)
locales-en-2.12.1-1mdv2011.0.i586
 (z důvodu nesplněného locales == 2.12.1-1mdv2011.0)
mdkonline-2.77.21-1.2mdv2010.1.noarch
 (z důvodu nesplněného rpmdrake >= 5.11.1,
  z důvodu chybějícího perl(Rpmdrake::open_db),
  z důvodu nesplněného urpmi >= 6.17)
myspell-cs_CZ-1.0.2-29mdv2010.1.noarch
 (z důvodu chybějícího locales-cs)
myspell-en_US-1.0.2-29mdv2010.1.noarch
 (z důvodu chybějícího locales-en)
perl-URPM-3.37.1-1.2mdv2010.1.i586
 (z důvodu nesplněného rpm >= 1:4.6.0)
python-2.6.5-2.2mdv2010.1.i586
 (z důvodu nesplněného libpython2.6 == 2.6.5)
python-cups-1.9.49-1mdv2010.1.i586
 (z důvodu nesplněného python < 2.7)
python-exo-0.3.106-2mdv2010.1.i586
 (z důvodu nesplněného python < 2.7)
python-imaging-1.1.7-1mdv2010.1.i586
 (z důvodu nesplněného python < 2.7)
python-rpm-4.6.0-14mnb2.i586
 (z důvodu nesplněného rpm == 1:4.6.0-14mnb2)
python-scipy-0.7.2-2mdv2010.1.i586
 (z důvodu nesplněného python < 2.7)
python-sip-4.10.1-1mdv2010.1.i586
 (z důvodu nesplněného python < 2.7)
rpm-4.6.0-14mnb2.i586
 (z důvodu nesplněného librpm4.6 == 1:4.6.0-14mnb2)
rpmdrake-5.26.3.3-1.2mdv2010.1.noarch
 (z důvodu chybějícího perl(URPM::Signature),
  z důvodu nesplněného perl-URPM >= 3.07-2,
  z důvodu chybějícího perl(URPM),
  z důvodu chybějícího perl(URPM::Resolve),
  z důvodu nesplněného urpmi > 6.18)
smart-1.3.1-0.r948.1mdv2010.1.i586
 (z důvodu chybějícího python-rpm)
smart-gui-1.3.1-0.r948.1mdv2010.1.i586
 (z důvodu nesplněného smart == 1:1.3.1-0.r948.1mdv2010.1)
task-printing-hp-2010-2mdv2010.1.i586
 (z důvodu nesplněného task-printing-server == 2010-2mdv2010.1,
  z důvodu nesplněného gutenprint-cups >= 5.0.1)
task-printing-server-2010-2mdv2010.1.i586
 (z důvodu nesplněného cups >= 1.3.0)
task-xfce-4.6.1-4mdv2010.0.noarch
 (z důvodu chybějícího task-xfce-minimal)
task-xfce-minimal-4.6.1-4mdv2010.0.noarch
 (z důvodu chybějícího thunar,
  z důvodu chybějícího thunar-volman)
task-xfce-plugins-4.6.1-4mdv2010.0.noarch
 (z důvodu chybějícího task-xfce-minimal)
thunar-1.0.1-7mdv2010.1.i586
 (z důvodu nesplněného libthunar1_2 == 1.0.1-7mdv2010.1,
  z důvodu chybějícího thunar-volman)
thunar-media-tags-plugin-0.1.2-11mdv2010.1.i586
 (z důvodu nesplněného thunar >= 0.8.0)
thunar-thumbnailers-0.4.1-4mdv2010.1.i586
 (z důvodu nesplněného thunar >= 0.8.0)
thunar-thumbnailers-ffmpeg-0.4.1-4mdv2010.1.i586
 (z důvodu chybějícího thunar-thumbnailers)
thunar-volman-0.3.80-6mdv2010.1.i586
 (z důvodu nesplněného thunar >= 0.8.0)
tkinter-2.6.5-2.2mdv2010.1.i586
 (z důvodu nesplněného python == 2.6.5)
urpmi-6.38-1mdv2010.1.noarch
 (z důvodu chybějícího perl(URPM),
  z důvodu chybějícího perl(URPM::Resolve),
  z důvodu chybějícího genhdlist2)
userdrake-1.13-1mdv2010.1.i586
 (z důvodu nesplněného drakxtools >= 12.49)
xfce4-rss-plugin-0.1.0-8mdv2010.1.i586
 (z důvodu chybějícího python-exo)
xfce4-smartpm-plugin-0.4.0-5mdv2010.1.i586
 (z důvodu chybějícího smart-gui)
xfswitch-plugin-0.0.1-5mdv2010.1.i586
 (z důvodu chybějícího gdm)

Co s tím? Jak přejít zpět na cooker verzi bez stahování iso souborů a vypalovaní CD/DVD?
Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #1 : April 22, 2011, 19:01:43 »

A co urpmi --auto-update? Jaký je obsah souboru /etc/urpmi/urpmi.cfg

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
medulin
Sr. Member
****

Karma: 0
: 283


« #2 : April 22, 2011, 19:16:22 »

A co urpmi --auto-update?
Jaký je obsah souboru /etc/urpmi/urpmi.cfg

:
 urpmi --auto-update
zdroj "Main" je aktuální
zdroj "Main Updates" je aktuální
zdroj "Contrib" je aktuální
zdroj "Contrib Updates" je aktuální
Dále to pokračuje a končí stejně jako urpmi --auto-select


:
  cat /etc/urpmi/urpmi.cfg
{
  downloader: wget
  verify-rpm: 1
  xml-info:
}

Main  {
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  update
  with-dir: media/main/release
}

Main\ Updates  {
  key-ids: 22458a98
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  update
  with-dir: media/main/updates
}

Main\ Testing  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/main/testing
}

Main\ Backports  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/main/backports
}

Main\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_main/release
}

Main\ Updates\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_main/updates
}

Main\ Testing\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_main/testing
}

Main\ Backports\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_main/backports
}

Contrib  {
  key-ids: 26752624
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  update
  with-dir: media/contrib/release
}

Contrib\ Updates  {
  key-ids: 26752624
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  update
  with-dir: media/contrib/updates
}

Contrib\ Testing  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/contrib/testing
}

Contrib\ Backports  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/contrib/backports
}

Contrib\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_contrib/release
}

Contrib\ Updates\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_contrib/updates
}

Contrib\ Testing\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_contrib/testing
}

Contrib\ Backports\ debug  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_contrib/backports
}

Non-free  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  update
  with-dir: media/non-free/release
}

Non-free\ Updates  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  update
  with-dir: media/non-free/updates
}

Non-free\ Testing  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/non-free/testing
}

Non-free\ Backports  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/non-free/backports
}

debug_non-free_release  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_non-free/release
}

debug_non-free_updates  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_non-free/updates
}

debug_non-free_testing  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_non-free/testing
}

debug_non-free_backports  {
  ignore
  mirrorlist: http://api.mandriva.com/mirrors/basic.cooker.i586.list
  with-dir: media/debug_non-free/backports
}

PLF\ Free  {
  ignore
  key-ids: caba22ae
  mirrorlist: http://plf.zarb.org/mirrors/cooker.i586.list
  update
  with-dir: media/../../../../cooker/free/binary/i586
}

PLF\ Free\ debug  {
  ignore
  mirrorlist: http://plf.zarb.org/mirrors/cooker.i586.list
  with-dir: media/../../../../cooker/free/debug/i586
}

PLF\ Non-free  {
  ignore
  mirrorlist: http://plf.zarb.org/mirrors/cooker.i586.list
  with-dir: media/../../../../cooker/non-free/binary/i586
}

PLF\ Non-free\ debug  {
  ignore
  mirrorlist: http://plf.zarb.org/mirrors/cooker.i586.list
  with-dir: media/../../../../cooker/non-free/debug/i586
}
« : April 22, 2011, 19:19:31 medulin »
medulin
Sr. Member
****

Karma: 0
: 283


« #3 : April 22, 2011, 19:33:45 »

Pokusil jsem se zvlášť nainstalovat ten basesystem, ale v textu to vůbec nic nenapsalo:
:
 [root@localhost urpmi]# urpmi basesystem


[root@localhost urpmi]#

A přes balíčkovač vyskočilo toto okno:

Přitom balíček existuje: http://mandriva.mirror.dkm.cz/pub/mandriva/devel/2011.0/i586/media/main/release/basesystem-2011.0-1-mdv2011.0.i586.rpm, http://mandriva.mirror.dkm.cz/pub/mandriva/devel/2011.0/i586/media/main/release/basesystem-minimal-2011.0-1-mdv2011.0.i586.rpm

Peťoš
Global Moderator
Hero Member
*****

Karma: 188
: 6 712



« #4 : April 22, 2011, 19:36:42 »

blbá otázka ale udělal jsi, že
  • Změna repozitářů
  • urpmi urpmi
  • až pak aktualizace

Ono je možné, že bude zlobit přechod RPM4>RPM5... Ale já asi dva týdny zpět nahodil cooker a v pohodě...

Do it or do not. There is no "try".

Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky
medulin
Sr. Member
****

Karma: 0
: 283


« #5 : April 22, 2011, 19:58:35 »

Zapomněl  
:
 [root@localhost urpmi]# urpmi urpmi
Požadovaný balíček nelze nainstalovat:
libaugeas0-0.8.0-1-mdv2011.0.i586 (z důvodu nesplněného augeas-lenses[== 0.8.0-1])
Přesto pokračovat v instalaci? (A/n) a
[root@localhost urpmi]#

nainstalovalo se urpmi-6.58
Oprava: nenainstalovalo se urpmi 

Ale urpmi --auto-select končí pořád stejně  
« : April 22, 2011, 20:13:43 medulin »
medulin
Sr. Member
****

Karma: 0
: 283


« #6 : April 22, 2011, 20:21:30 »

Problém je v tomto balíčku: http://mandriva.mirror.dkm.cz/pub/mandriva/devel/2011.0/i586/media/main/release/augeas-lenses-0.8.0-1-mdv2011.0.i586.rpm nejde mi nainstalovat a tím pádem ani urpmi. 
: [1]
   |   
 
: