Přihlásit
: [1]
   |   
: Chybějící "libdha.so.1.0" v checkinstall pro MPlayer  ( 3337 )
Mirek Škařupa
Newbie
*

Karma: 0
: 25


« : November 19, 2006, 21:24:54 »

Ahoj,
při instalaci MPlayeru:

./configure --enable-gui
make
checkinstall

mi potom vyskočila hláška (posledních pár podle mne rozhodujících řádků):

install -m 755  -p libdha.so.1.0  /usr/local/lib/libdha.so.1.0
install: zachování časů souboru `/usr/local/lib/libdha.so.1.0': není souborem ani adresářem
install: cannot set time stamps for `/usr/local/lib/libdha.so.1.0': není souborem ani adresářem
make[1]: *** [install] Error 1
make[1]: Leaving directory `/home/mirek/Stažené/MPlayer-1.0rc1/libdha'
make: *** [install] Error 2

****  Installation failed. Aborting package creation.

Cleaning up...OK

Bye.

Úspěšně jsem i něco jako "libdha.so.1.0" nainstaloval, ale pořád to hlásí to samé.

Díky za radu pokud někdo bude vědět.
Adam Rambousek
Full Member
***

Karma: 1
: 201


« #1 : November 20, 2006, 01:44:23 »

a proč ne mplayer z PLF?
Mirek Škařupa
Newbie
*

Karma: 0
: 25


« #2 : November 20, 2006, 02:07:38 »

Protože chci vyzkoušet vytváření vlastních RPM balíčků pomocí "checkinstall".
Luděk Sladký
Hero Member
*****

Karma: 4
: 1 358


« #3 : November 20, 2006, 09:40:10 »

Možná by bylo dobré tomu ./configure předhodit prefix, který by směroval binárky a knihovny do /usr nikoliv implicitně do /usr/local. Nejsem si jist, ale mohlo by to být asi nějak takto ./configure --prefix=/usr.
Guest
« #4 : November 20, 2006, 16:51:04 »

Mplayer je dost komplexni program, u mne taky checkinstall nezabral, prestoze jine programy v pohode zkompiluje. Dal jsem se tim nezabyval.
Jiří Hlinka
Newbie
*

Karma: 0
: 165


« #5 : November 20, 2006, 18:04:36 »

Zdravím,
nepomůže spustit checkinstall s parametrem "--fstrans=no", tedy:
checkinstall --fstrans=no
?
Mirek Škařupa
Newbie
*

Karma: 0
: 25


« #6 : November 20, 2006, 21:15:01 »

Díky,
zkoušel jsem obě uvedené rady, ale ani jedno nepomohlo.
Přesto díky.
Jiří Hlinka
Newbie
*

Karma: 0
: 165


« #7 : November 21, 2006, 13:41:42 »

a balíček "libdha" máte nainstalovaný?
Mirek Škařupa
Newbie
*

Karma: 0
: 25


« #8 : November 21, 2006, 19:38:08 »

Ano, už v prvním příspěvku jsem psal, že jsem zkusil nainstalovat "něco" jako "libdha.so.1.0", ale vůbec si nejsem jistý, jestli to byl ten správný balíček. Nic lepšího jsem nedokázal stáhnout, tak jsem nainstaloval aspoň toto a pořád nic. Pokud by někdo věděl, kde stáhnout "to pravé ořechové libdha", tak bych byl vděčný.
Jiří Hlinka
Newbie
*

Karma: 0
: 165


« #9 : November 21, 2006, 22:41:09 »

Aha, já jsem měl na mysli prostě tohle:
urpmi libdha
...jinak už fakt nevím, zkuste zagooglit libdha + checkinstall, vyhodí to dost výsledků, snad se tam něco najde, nehledal jsem moc dlouho.
Hodně štěstí :-),
Jirka
Mirek Škařupa
Newbie
*

Karma: 0
: 25


« #10 : November 22, 2006, 00:21:44 »

Nainstaloval jsem nakonec klasický RPM balíček a je to OK.
Díky všem za rady.
hajma
Sr. Member
****

Karma: 5
: 379


« #11 : November 22, 2006, 12:49:10 »

a nechceš si raději stáhnout src.rpm toho mplayeru, upravit si, co je potřeba a rebuildnout? Oproti checkinstallu menší pravděpodobnost, že to nevyjde ...
Mirek Škařupa
Newbie
*

Karma: 0
: 25


« #12 : November 22, 2006, 20:51:03 »

Jak jsem již uvedl na jiný dotaz, šlo mi spíš o vyzkoušení toho "checkinsall". Ale díky za reakci.
: [1]
   |   
 
: