Přihlásit
: [1]
   |   
: Stale stary software - copak je to s mandrivou?  ( 2429 )
Cyder
Full Member
***

Karma: 0
: 160


BattleStar Pegasus - www.bsg.cz


« : November 29, 2008, 20:05:34 »

Zdravíčko vim že tady asitěžko někdo ovlivní dění u spravců repozitařů ale ason dotaz. Co to sakra ma byt? dva měsíce od vydání, OpenOffice stale RC verze, Gimp, zcela ignorovan, Virtualbox dvě verze pozadu, wine taktéž. Nechapu, tohle je představa moderního systemu? ta vymluva "ověřvani stability" je trošku o něčem jinym.

Ještě že vlevate novou žilu do starších verzí, když vyrobce na 2009ku kašle. to se pak budou všichni divit když preference mandrivy padnou. Možna by stalo za to začí publikovat navody jak si sami tvořit balíčky, abychom ten system trošku aktualni a použitelny měli.

Ma tu někdo kontakt s vyrobci? že by se třeba aspon mohl objevit članek "proč mandriva starne" ?

Když už si chce člověk něco nainstalovat tak to pro změnu nejde, a to několik tydnu, pry "chybne RPM baličky" http://imajr.com/Original.aspx?Id=rgggggewr-1297601
Hobil
Hero Member
*****

Karma: 58
: 4 006


« #1 : November 29, 2008, 20:38:37 »

něco se dá najít tady, ale taky nejsou k dispozici vždy nejnovější balíčky:
http://wiki.mandrivalinux.cz/tvorba-rpm-zkraceno#nejjednodussi_cestaze_souboru_src.rpm_ii
H.

edit: virtualbox je napr. zde:
ftp://ftp.free.fr/mirrors/ftp.mandriva.com/MandrivaLinux/devel/cooker/SRPMS/main/release/virtualbox-2.0.6-1mdv2009.1.src.rpm

Takze kdo chce vyrobcem oficialne podporovane verze (lze ocekavat vyssi uroven spolehlivosti a bezpecnosti), necha si tu distribucni
kdo z nejakeho duvodu nutne potrebuje novejsi verzi, ma moznost.
H.
« : November 29, 2008, 20:47:31 Hobil »

Benzínem se nemá hasit ohniště
teď už je to jedno, ale pro příště... (K.P.)
karel kudrna
Hero Member
*****

Karma: 14
: 567


skill :: googllama jabber:patryk@jabber.cz


« #2 : November 30, 2008, 13:52:47 »

Tedy nevím jak jiní, ale já nedávám přednost systému sestavenému z nejnovějších verzí...naopak některé věci řeším starší verzí softu...Xakru, proč je Debian stable tak zoufale nemoderní? Není to chyba?

prostý user
...selským rozumem...
pert2
Sr. Member
****

Karma: 9
: 291


« #3 : November 30, 2008, 16:08:04 »

To není chyba, to je feature
Ivan Bibr
Administrator
Hero Member
*****

Karma: 52
: 3 298



« #4 : November 30, 2008, 19:46:59 »

Zdravíčko vim že tady asitěžko někdo ovlivní dění u spravců repozitařů ale ason dotaz. Co to sakra ma byt? dva měsíce od vydání, OpenOffice stale RC verze, Gimp, zcela ignorovan, Virtualbox dvě verze pozadu, wine taktéž. Nechapu, tohle je představa moderního systemu? ta vymluva "ověřvani stability" je trošku o něčem jinym.

Netuším, oč přesně tady jde. Mandriva není rolling-updates distro, verze zůstávají stejné po celou dobu životnosti distra, pouze se opravují chyby. To, co požadujete, je obvykle v backports.

PS netýká se OOo RC2, to asi ještě nebyli schopni ubalit . My jo:
http://www.mandrivalinux.cz/openoffice-3-0-pro-mdv-2008-1
 

Cyder
Full Member
***

Karma: 0
: 160


BattleStar Pegasus - www.bsg.cz


« #5 : December 04, 2008, 17:58:33 »

Gimp 2.4.7 byl i v Mandrivě 2008 spring

Takže aktualni verze se zřejmě dočkam v 2009.1
Ivan Bibr
Administrator
Hero Member
*****

Karma: 52
: 3 298



« #6 : December 04, 2008, 18:29:51 »

Gimp 2.4.7 byl i v Mandrivě 2008 springTakže aktualni verze se zřejmě dočkam v 2009.1

Gimp 2.4.7 je poslední verze řady 2.4. Řada 2.6 nebyla do release plánu zahrnuta (stačí se podívat na datum vydání - 1. 10. a je jasno). Stále nechápu, o co vám jde. Jestli nemáte jasno v mandrivácké politice pro vydávání verzí, podívejte se na http://wiki.mandriva.com. Jestli vám nevyhovuje, můžete se klidně přidat a změnit to. Jestli to nezvládnete, tak si najděte nějaké distro s rolling updates

Kdybyste se jen trochu snažil, tak ten nový Gimp najdete.


Cyder
Full Member
***

Karma: 0
: 160


BattleStar Pegasus - www.bsg.cz


« #7 : December 05, 2008, 14:20:30 »

Ja sem si gimp našel. Mandrivacka politika mi vskutku nevyhovuje. Chapu že se u Mandrivy nevede Rollings update, ale kvuli tomu že v planu se někomu libi 2.4 tak uživatelum rok předhazovat překonane a už hodně stare verze jen aby v nějakem planu nebylo 2.6.

Ja si ten gimp našel, ale pak mužeme zapomenout na repozitaře, každou aplikaci si kontrolovat sam, jestli už nahodou neni nova verze, a občas se podivat copak to za stařešiny je v repozitaři.
Ivan Bibr
Administrator
Hero Member
*****

Karma: 52
: 3 298



« #8 : December 05, 2008, 18:30:56 »

Ja sem si gimp našel. Mandrivacka politika mi vskutku nevyhovuje.

Je problém přejít jinam?

Chapu že se u Mandrivy nevede Rollings update, ale kvuli tomu že v planu se někomu libi 2.4 tak uživatelum rok předhazovat překonane a už hodně stare verze jen aby v nějakem planu nebylo 2.6.

No, vzhledem k tomu že vydání GIMpu 2.6 bylo naplánováno na 1.10. těžko se dostane do distra, které bylo 9. 10. na mirrorech (version freeze v září, ISO build 2.10.). Vývojáři Mandrivy jsou prostě takový mejdla, že to nedali . Jestli vy to dáte, není nic jednoduššího než se připojit s Mandriva týmu. Uspokojíte nejen sebe, ale i ostatní podobně nespokojené uživatele. Uvítám to samozřejmě i já a asi všichni tady...

Ja si ten gimp našel, ale pak mužeme zapomenout na repozitaře,

Asi jste špatně hledal, já vidím 2.6 přímo v Contribu.

každou aplikaci si kontrolovat sam, jestli už nahodou neni nova verze, a občas se podivat copak to za stařešiny je v repozitaři.

No jo, ale s tím holt nic nenaděláte. Politiku vydávání Mandrivy znáte a stěžovat si na ni je stejný nesmysl jako si stěžovat, že je nebe modré. Jeslti to chcete změnit, můžete se přidat k vývojářům a nebo jako někteří jiní uživatelé si sem tam sám něco ubalit. To druhé je jednodušší a pár lidí to tady dělá, že jo, já ostatně taky. Nebo můžete jet na Cookeru.

Pozor, nechci tím říct, že se vším s Mandrivou souhlasím a že všechny balíčky jsou v pořádku, to ani náhodou, na to ji znám moc dobře (distro i firmu). Co můžu, to se snažím nějak popíchnout, napravit nebo udělat jinak. Ale problém je v tom, že vy si stěžujete na něco, co Mandriva říká, že dělat nebude. To je to, co mírně řečeno (a při vší slušnosti) vůbec nechápu. Prostě jestli chcete opravdový rolling updates, musíte si najít jiné distro. Konec, tečka. Nač se pídit po tom, co proč a jak dělají vývojáři Mandrivy?

Stejně nechápu to pachtění za novými verzemi. Považuji se za poměrně pokročilého a náročného uživatele, ale téměř vždy si vystačím s tím, co mám. Drtivé většině uživatelů by naopak prospělo (a neříkám to adresně), kdyby se alespoň z desetiny naučili používat stávající nástroje a stávající verze. Místo toho se pachtí za novými a novými verzemi něčeho, co a ni neumí ovládat (znovu opakuji, že to neříkám adresně)...

Problém přístupu "proč tam není verze A a B" je ten, že vždy vyjde nějaké nová verze něčeho, na co by se hodilo počkat. KDE, Gnome, GIMP, OOo, X.org, kernel, gcc, Amarok, Scribus atd. atd. atd. S takovým přístupem není možné dát dohromady funkční distro nikdy, protože by se pořád na něco čekalo. Proto máme dva různé přístupy: rolling updates a to, co používá Mandriva (a celý mainstream).

Znovu opakuji: Mandriva není rolling update distro. Jestli to chcete, musíte si najít distro zcela jiného typu. Moje tipy:

http://www.gentoo.org/
http://www.archlinux.org/

: [1]
   |   
 
: